Author Topic: FluffOS Compile problems  (Read 8915 times)

Offline boobay

  • Acquaintance
  • *
  • Posts: 41
    • View Profile
Re: FluffOS Compile problems
« Reply #15 on: June 05, 2007, 04:43:15 PM »
Could you send your changes to wodan@wodan.pressanykey.nl ?

Your crash is probably gone if you compile without DEBUG, introduced a crasher there in 2.6, oops!

Offline lyoc

  • Acquaintance
  • *
  • Posts: 7
    • View Profile
Re: FluffOS Compile problems
« Reply #16 on: June 05, 2007, 07:59:49 PM »
Could you send your changes to wodan@wodan.pressanykey.nl ?

Your crash is probably gone if you compile without DEBUG, introduced a crasher there in 2.6, oops!

Hi b, thanks for the reply. That didn't solve the problem on my server (7.04 LTS Ubuntu, latest gcc &c.), guess I must be the odd man out. I get a cleaner compile without debug as far as warnings, however.

Offline boobay

  • Acquaintance
  • *
  • Posts: 41
    • View Profile
Re: FluffOS Compile problems
« Reply #17 on: June 05, 2007, 08:03:34 PM »
Could you post the problems that you're having? Are you only having a segmentation fault? What types of warnings are you receiving while compiling?

All the information is helpful :)

Offline lyoc

  • Acquaintance
  • *
  • Posts: 7
    • View Profile
Re: FluffOS Compile problems
« Reply #18 on: June 05, 2007, 08:28:37 PM »
I resolved the problem by copying the lib directory out of the dw dist that crat posted to this site and running it with the driver I compiled from the newest dw fluffos release. When attempting to run the official dw lib (numbered 9.99 release), it seg faults and thats all I get. No core dump or anything. The driver compiles fine, I get a few more warnings when I compile with the develop options but it is otherwise okay. The game is up and running now, just thought I would share what I had to do to get a working lib.

Offline sojan

  • Acquaintance
  • *
  • Posts: 35
    • View Profile
Re: FluffOS Compile problems
« Reply #19 on: June 06, 2007, 04:31:31 AM »
Ah,  Definately worth noting that 9.99 probably won't work with newer fluffos very well as theres been quite a few changes since then.  I'm putting together a new DWlib release for later this year that will be far more compatible.

J