Author Topic: reboot problem  (Read 5406 times)

Offline cratylus

  • Your favorite and best
  • Administrator
  • ***
  • Posts: 1024
  • Cratylus@Dead Souls <ds> np
    • View Profile
    • About Cratylus
reboot problem
« on: January 01, 2007, 01:19:27 pm »
Does anyone know how to disable Discworld's 20-minute interval reboots? I
thought I edited the right file, but no dice.

-Crat

Offline sojan

  • Acquaintance
  • *
  • Posts: 35
    • View Profile
Re: reboot problem
« Reply #1 on: January 12, 2007, 04:38:23 am »
The file you need to edit is /obj/handlers/garbage.c to turn off timed reboots add

#define NO_TIMED_REBOOT 1

To turn off the reboot that is automatic based upon memory usage and page faults add

#define NO_AUTO_REBOOT 1

alternatively adjust the values of MIN_TIME, MAX_TIME and FAULT_RATE

you probably also want to mak sure the adaptive reboot capability is turned off with

#define NO_ADAPTIVE_REBOOT 1

Regards

J


Offline cratylus

  • Your favorite and best
  • Administrator
  • ***
  • Posts: 1024
  • Cratylus@Dead Souls <ds> np
    • View Profile
    • About Cratylus
Re: reboot problem
« Reply #2 on: January 12, 2007, 09:54:53 am »
That worked!

Thank y ou.

-Crat

Offline sojan

  • Acquaintance
  • *
  • Posts: 35
    • View Profile
Re: reboot problem
« Reply #3 on: January 12, 2007, 07:01:48 pm »
One would hope it did since I wrote some of the code in question!

Bings

J
« Last Edit: April 21, 2007, 10:22:42 am by sojan »