Author Topic: WIP: Fluffos 3.0 Alpha 9.0  (Read 3951 times)

Offline DarKWateR

  • BFF
  • ***
  • Posts: 104
    • View Profile
Re: WIP: Fluffos 3.0 Alpha 9.0
« Reply #15 on: October 16, 2015, 11:12:03 AM »
Perfect, i update it and i'll testing again with this version of driver.

Thank you very much!

Offline DarKWateR

  • BFF
  • ***
  • Posts: 104
    • View Profile
Re: WIP: Fluffos 3.0 Alpha 9.0
« Reply #16 on: October 16, 2015, 12:08:09 PM »
Hello, i can't compile driver.

Error:
Code: [Select]
checking for libevent >= 2.0... no
configure: error: Fail to find libevent (2.0+) header/library, install libevent-dev or change --with_libevent

With Version 8.1 is ok and with previous versión 9.0 too.

Offline FallenTree

  • BFF
  • ***
  • Posts: 476
    • View Profile
Re: WIP: Fluffos 3.0 Alpha 9.0
« Reply #17 on: October 21, 2015, 10:18:31 AM »
I am working on fixing that.

Offline FallenTree

  • BFF
  • ***
  • Posts: 476
    • View Profile
Re: WIP: Fluffos 3.0 Alpha 9.0
« Reply #18 on: October 26, 2015, 09:51:36 AM »
Hello, i can't compile driver.

This has been fixed by the latest commit. Also, I think i‘ve also fixed the crash, please try again.

Offline DarKWateR

  • BFF
  • ***
  • Posts: 104
    • View Profile
Re: WIP: Fluffos 3.0 Alpha 9.0
« Reply #19 on: October 26, 2015, 02:20:26 PM »
Perfect, now is ok!

Tomorrow i'll come back to this version for tests.

Thank you very much!

Offline FallenTree

  • BFF
  • ***
  • Posts: 476
    • View Profile
Re: WIP: Fluffos 3.0 Alpha 9.0
« Reply #20 on: October 28, 2015, 12:13:37 AM »
Perfect, now is ok!

Tomorrow i'll come back to this version for tests.

Thank you very much!

Great , how did it go? Assuming everything is working okay?

Offline DarKWateR

  • BFF
  • ***
  • Posts: 104
    • View Profile
Re: WIP: Fluffos 3.0 Alpha 9.0
« Reply #21 on: October 28, 2015, 12:31:08 AM »
Hello, yes, for now all is ok!

Offline DarKWateR

  • BFF
  • ***
  • Posts: 104
    • View Profile
Re: WIP: Fluffos 3.0 Alpha 9.0
« Reply #22 on: November 06, 2015, 01:04:44 AM »
Hello! Today driver crash again.

Same error, in telnet_recv.

Uptime was: around 6 days.

Offline FallenTree

  • BFF
  • ***
  • Posts: 476
    • View Profile
Re: WIP: Fluffos 3.0 Alpha 9.0
« Reply #23 on: November 09, 2015, 09:15:01 AM »
do you have core available?

Offline DarKWateR

  • BFF
  • ***
  • Posts: 104
    • View Profile
Re: WIP: Fluffos 3.0 Alpha 9.0
« Reply #24 on: November 09, 2015, 11:48:30 PM »
Do you mean "rlimit"?

WARNING: rlimit for core dump is 0, you will not get core on crash.

Start driver:
Code: [Select]
========================================================================
Boot Time: Tue Nov 10 06:44:02 2015
FluffOS Version: 3.0-alpha9.0(git-944ee22-1443467939)@ (Linux/x86-64)
Jemalloc Version: 4.0.3-0-ge9192eacf8935e29fc62fddc2701f7942b1cc02c
Core Dump: No, Max FD: 65535
Command: ./driver ./config.rl
========================================================================

do you need that load driver with rlimit?
Which is the command for activate it?

Offline FallenTree

  • BFF
  • ***
  • Posts: 476
    • View Profile
Re: WIP: Fluffos 3.0 Alpha 9.0
« Reply #25 on: November 10, 2015, 09:24:38 AM »
You would need to do this :

ulimit -c unlimited && ./driver xxxx

Verify that driver startup without the warning.  And when it crash, send me the core.xxx file , together with the driver binary. I will be able to see what this is about.

Also , can you paste the crash log again?

Offline DarKWateR

  • BFF
  • ***
  • Posts: 104
    • View Profile
Re: WIP: Fluffos 3.0 Alpha 9.0
« Reply #26 on: November 10, 2015, 11:55:40 PM »
hello, trace is:
Code: [Select]
/home/mud/rlmud/driver/bin/driver(+0xd5415)[0x7f2db9e27415]
/lib/x86_64-linux-gnu/libc.so.6(+0x35180)[0x7f2db74c3180]
/home/mud/rlmud/driver/bin/driver(+0xd4a40)[0x7f2db9e26a40]
/home/mud/rlmud/driver/bin/driver(+0xd1f38)[0x7f2db9e23f38]
/home/mud/rlmud/driver/bin/driver(+0xd365a)[0x7f2db9e2565a]
/home/mud/rlmud/driver/bin/driver(telnet_recv+0x158)[0x7f2db9e14eb8]
/home/mud/rlmud/driver/bin/driver(_Z13get_user_dataP13interactive_t+0x571)[0x7f2db9e3bcd1]
/usr/lib/libevent-2.1.so.5(+0x1785c)[0x7f2db807085c]
/usr/lib/libevent-2.1.so.5(+0x209ae)[0x7f2db80799ae]
/usr/lib/libevent-2.1.so.5(event_base_loop+0x49f)[0x7f2db807a32f]
/home/mud/rlmud/driver/bin/driver(_Z7backendP10event_base+0x26e)[0x7f2db9e18f0e]
/home/mud/rlmud/driver/bin/driver(main+0x302)[0x7f2db9d71d42]
/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf5)[0x7f2db74afb45]
/home/mud/rlmud/driver/bin/driver(+0x20475)[0x7f2db9d72475]
******** FATAL ERROR: SIGSEGV: Segmentation fault
FluffOS driver attempting to exit gracefully.
crash() in master called successfully.  Aborting.

This trace is for fluffos 8.1 too :(

i'll try core.

Offline quixadhal

  • BFF
  • ***
  • Posts: 618
    • View Profile
    • A Waste of Time
Re: WIP: Fluffos 3.0 Alpha 9.0
« Reply #27 on: November 11, 2015, 04:31:12 AM »
It's probably also helpful to compile with the debug flags on, and link against the debug versions of your system libraries.  ./build_FluffOS devel used to do this (or maybe debug).

If you know how to reproduce the crash, or you have beefy enough hardware to not mind the overhead, you can also run the driver in gdb, which would let you poke around in the case of a crash.  If you do that though, I'd recommend using screen, or doing it on a console.... a remote shell without screen may stop the driver if you get disconnected.

Offline DarKWateR

  • BFF
  • ***
  • Posts: 104
    • View Profile
Re: WIP: Fluffos 3.0 Alpha 9.0
« Reply #28 on: November 11, 2015, 02:23:43 PM »
For now i can't reproduce this bug and i can't compile in debug mode (lag for players :()
I'm trying gdb with a coredump for a crash forced by me (for testings purposes)...
When crash again for that error, i'll try it.

Thank you very much!


Offline FallenTree

  • BFF
  • ***
  • Posts: 476
    • View Profile
Re: WIP: Fluffos 3.0 Alpha 9.0
« Reply #29 on: November 12, 2015, 09:28:54 PM »
can you also use addr2line to get correct line number from your above crash stacktrace ?