Author Topic: connection  (Read 2611 times)

Offline cindel

  • Acquaintance
  • *
  • Posts: 9
    • View Profile
connection
« on: June 08, 2014, 05:23:16 PM »
My mud is up and running but I cannot connect to it using the actual ip address, only 'localhost <port#>' on the same machine that it's running on. I also tried connecting to the mud from a different computer but no success. Could this be a network issue I need to adjust and if so, how?

Step by step instructions would be great. Thanks.

Offline quixadhal

  • BFF
  • ***
  • Posts: 631
    • View Profile
    • WileyMUD
Re: connection
« Reply #1 on: June 08, 2014, 09:33:32 PM »
Too many variables there.

What OS are you using?  Does it have a software firewall enabled?  Are you behind a NAT router?  Can your other machines access any other services on the server's machine?  When you set up the MUD, is it listening on all network addresses, or only on localhost (127.0.0.1)?

Offline cindel

  • Acquaintance
  • *
  • Posts: 9
    • View Profile
Re: connection
« Reply #2 on: June 08, 2014, 11:11:45 PM »
The mud is running on a Oracle VM VirtualBox with FreeBSD 9.2 as the OS. The VirtualBox is running on Windows 7 Home. The windows 7 probably has a firewall but as for the FreeBSD, not sure. All other machines can access the internet and do just about anything except connect the mud. The mud settings are fine because there was a point when a connection to the mud was possible in the old FreeBSD machine before the computer fried. I simply moved a backup of the  mud to this VirtualBox FreeBSD. As far as the router, it's just standard, not NAT. The router is also another thing that hasn't changed back when there was a successful connection.

Offline quixadhal

  • BFF
  • ***
  • Posts: 631
    • View Profile
    • WileyMUD
Re: connection
« Reply #3 on: June 08, 2014, 11:32:55 PM »
Is the Virtualbox VM set up to use bridged networking, or private nat?  If I remember right, the default is private, which creates a virtual NIC with one of the private IP ranges, which you'll only be able to access from the host machine itself, unless you forward ports via windows firewall.

Offline cindel

  • Acquaintance
  • *
  • Posts: 9
    • View Profile
Re: connection
« Reply #4 on: June 08, 2014, 11:59:23 PM »
That's a good starting point. I'll definitely look into that and post what happens.

Offline cindel

  • Acquaintance
  • *
  • Posts: 9
    • View Profile
Re: connection
« Reply #5 on: June 09, 2014, 04:52:27 PM »
As for the firewall settings in windows 7, I have Private and Public enabled.
Ok there are a few things about the VirtualBox VM that I'm unsure of. I attached an image for some detailed specs and I need to know which options to set.
« Last Edit: June 09, 2014, 05:03:41 PM by cindel »

Offline cindel

  • Acquaintance
  • *
  • Posts: 9
    • View Profile
Re: connection
« Reply #6 on: June 09, 2014, 05:25:27 PM »
As for the firewall settings in windows 7, I have Private and Public enabled.
Ok there are a few things about the VirtualBox VM that I'm unsure of. I attached an image for some detailed specs and I need to know which options to set.

Offline quixadhal

  • BFF
  • ***
  • Posts: 631
    • View Profile
    • WileyMUD
Re: connection
« Reply #7 on: June 09, 2014, 08:17:10 PM »
Bridged will put your VM on the same ethernet segment as your host PC,  and thus your VM will appear as another NIC to the rest of the network.  That's what I use, and thus have my DHCP server give it a fixed address.  If you were to choose NAT, it would put your VM on a private network treating your host PC as a NAT router.

Can you ping out from the console login of the VM?

Offline cindel

  • Acquaintance
  • *
  • Posts: 9
    • View Profile
Re: connection
« Reply #8 on: June 10, 2014, 12:41:50 AM »
I'm sorry please give me an example of the 'ping' thing you just mentioned. Better yet, if it's something I can type into the shell terminal let me know.

Offline quixadhal

  • BFF
  • ***
  • Posts: 631
    • View Profile
    • WileyMUD
Re: connection
« Reply #9 on: June 10, 2014, 08:44:49 AM »
Well, if you're logged into the VM via its console window (as root, probably), you should be inside the VM's environment.  If the linux system you installed in the VM is working properly, and the VM has been given an IP address, it should have the same outgoing network permissions as your host PC does.

So, if you pull open a DOS prompt, and type "ping google.com", it should be able to get some response back if you're on the internet, and your firewall isn't blocking you.

Likewise, if you are in your VM's console, typing "ping google.com", should result in nearly the same results.

If it does, then at least your linux install in the VM is working correctly.  At that point, you can try to determine if your VM settings are right, and if your firewall settings are right.

This assumes your VM is setup as either Bridged or NAT.  You can also set the VM to be fully private so it can only talk to other VM's on the same host... but it looked like that's not what you did. :)

I'm just trying to establish that outgoing connections work properly before tackling incoming ones.  MOST people don't set up their firewall to block outgoing connections, even if they block incoming ones... and I assume if you changed it to be more secure that way, you know you did it.

Offline cindel

  • Acquaintance
  • *
  • Posts: 9
    • View Profile
Re: connection
« Reply #10 on: June 21, 2014, 03:24:12 PM »
I did 'ping google.com' on the vm console as well as the dos prompt on the host pc. But the info is different as shown in the attached images.

As for the vm konsole, the same thing repeats over and over and does not stop until I close the window. The only thing that's different between each line is 'icmp_seq' is incremented by 1 and the 'time' is different.