Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - DarKWateR

Pages: [1] 2 3 ... 7
1
Drivers / Re: new year resolution
« on: January 09, 2016, 12:51:00 PM »
happy new year!

I've adapted smartjson in driver for tests in my mud. I use it for quick convert variables to json for gmcp sends.
Maybe implements json libraries in official driver is a good idea.

2
Drivers / Re: WIP: Fluffos 3.0 Alpha 9.0
« on: November 28, 2015, 05:49:56 AM »
yes, for now is running ok!

3
Drivers / Re: WIP: Fluffos 3.0 Alpha 9.0
« on: November 24, 2015, 12:58:05 PM »
Yeah! :D

4
Drivers / Re: WIP: Fluffos 3.0 Alpha 9.0
« on: November 23, 2015, 01:09:13 PM »
Hello, output is:
(gdb) print ip->local_port
$1 = 5001

(Incorrect coredump or binary?)
(gdb) x/4ub ((struct in_addr*)&((struct sockaddr_in*)&(ip->addr))->sin_addr)->s_addr
0xe71a64d0:     Cannot access memory at address 0xe71a64d0

(gdb)  x/36xb buf
0x7fffc2aa05a0: 0xff    0xfc    0x22    0xff    0xfa    0x22    0xff    0xf0
0x7fffc2aa05a8: 0xff    0xff    0xfc    0x03    0xff    0xfc    0x18    0xff
0x7fffc2aa05b0: 0xfc    0x1f    0xff    0xfc    0x27    0xff    0xfe    0x56
0x7fffc2aa05b8: 0xff    0xfc    0x5b    0xff    0xfe    0x46    0xff    0xfe
0x7fffc2aa05c0: 0x5d    0xff    0xfe    0xc9

Last output is the same.

i'll update with your path and cross my fingers!

5
Drivers / Re: WIP: Fluffos 3.0 Alpha 9.0
« on: November 20, 2015, 11:20:57 AM »
In my server, driver is add to systemctl.
That core is generated with systemd, because with ulimit didn't generate core in that situation.

surely i did something wrong, it was my first time with coredumps :D

6
Drivers / Re: WIP: Fluffos 3.0 Alpha 9.0
« on: November 18, 2015, 01:33:33 PM »
With full log, do you mean runtime_driver?
That log was deleted :(
the only useful info in it was stack trace, but that info is visible with gdb, isn't it?

The compress tar.gz core filesize are 56338715 MB.
Which are the max file_size for attachments in your mail? or do you have a ftp or similar?

I saw the core with gdb and in the moment of crash, i saw a telnet petition type TELNET_TELOPT_LINEMODE (34).
Perhaps some combination for some user and telnet client, and crash driver when enters? but i don't know, telnet protocol is new for me.

Thanks!

PD: Sorry my english

7
Drivers / Re: WIP: Fluffos 3.0 Alpha 9.0
« on: November 16, 2015, 02:14:44 AM »
Hello, this night driver crashed again.
I have the coredump, if you say me a mail i'll send you with the driver binary.

8
Drivers / Re: WIP: Fluffos 3.0 Alpha 9.0
« on: November 14, 2015, 11:49:09 AM »
You're right, my mud has active UTF-8.

9
Drivers / Re: WIP: Fluffos 3.0 Alpha 9.0
« on: November 14, 2015, 01:25:31 AM »
yes, the last backtrace is from fluffos 8.1.
After last crash from 9.0, i came back to fluffos 8.1 and finally crash too.

10
Drivers / Re: WIP: Fluffos 3.0 Alpha 9.0
« on: November 13, 2015, 11:12:24 AM »
That backtrace is from Fluffos 8.1, because i didn't save bt with last 9.0.
Note: Line Numbers from some files (main.cc) aren't exacts because some changes in my own driver version (I still don't send pull request), but i think that crash it is not due for this changes:

Used Command: addr2line -e ./driver "address"
Trace:
Code: [Select]
/home/mud/rlmud/driver/bin/driver(+0xd5415)[0x7f2db9e27415] => src/main.cc:203
/lib/x86_64-linux-gnu/libc.so.6(+0x35180)[0x7f2db74c3180] => rc/vm/internal/base/object.cc:1230
/home/mud/rlmud/driver/bin/driver(+0xd4a40)[0x7f2db9e26a40] => src/net/telnet.cc:220
/home/mud/rlmud/driver/bin/driver(+0xd1f38)[0x7f2db9e23f38] => src/thirdparty/libtelnet/libtelnet.c:813
/home/mud/rlmud/driver/bin/driver(+0xd365a)[0x7f2db9e2565a] => src/thirdparty/libtelnet/libtelnet.c:1052
/home/mud/rlmud/driver/bin/driver(telnet_recv+0x158)[0x7f2db9e14eb8] => ??:0 ???
/home/mud/rlmud/driver/bin/driver(_Z13get_user_dataP13interactive_t+0x571)[0x7f2db9e3bcd1] => ??:0 ???
/usr/lib/libevent-2.1.so.5(+0x1785c)[0x7f2db807085c]
/usr/lib/libevent-2.1.so.5(+0x209ae)[0x7f2db80799ae]
/usr/lib/libevent-2.1.so.5(event_base_loop+0x49f)[0x7f2db807a32f]
/home/mud/rlmud/driver/bin/driver(_Z7backendP10event_base+0x26e)[0x7f2db9e18f0e]
/home/mud/rlmud/driver/bin/driver(main+0x302)[0x7f2db9d71d42]
/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf5)[0x7f2db74afb45]
/home/mud/rlmud/driver/bin/driver(+0x20475)[0x7f2db9d72475]
******** FATAL ERROR: SIGSEGV: Segmentation fault
FluffOS driver attempting to exit gracefully.
crash() in master called successfully.  Aborting.

With GDB (With "info line"):
Code: [Select]
/home/mud/rlmud/driver/bin/driver(+0xd5415)[0x7f2db9e27415]
Line 203 of "main.cc" starts at address 0xd5415 <attempt_shutdown(int)+149> and ends at 0xd5428 <attempt_shutdown(int)+168>.
Code: [Select]
/lib/x86_64-linux-gnu/libc.so.6(+0x35180)[0x7f2db74c3180]
Line 1230 of "vm/internal/base/object.cc" starts at address 0x3517e <fgv_recurse(program_t*, int*, char*, unsigned short*, int) [clone .lto_priv.364]+1038>
   and ends at 0x35181 <fgv_recurse(program_t*, int*, char*, unsigned short*, int) [clone .lto_priv.364]+1041>.
Code: [Select]
/home/mud/rlmud/driver/bin/driver(+0xd4a40)[0x7f2db9e26a40]
Line 220 of "net/telnet.cc" starts at address 0xd4a40 <telnet_event_handler(telnet_t*, telnet_event_t*, void*) [clone .lto_priv.272]+1184>
   and ends at 0xd4a5d <telnet_event_handler(telnet_t*, telnet_event_t*, void*) [clone .lto_priv.272]+1213>.
Code: [Select]
/home/mud/rlmud/driver/bin/driver(+0xd1f38)[0x7f2db9e23f38]
Line 813 of "thirdparty/libtelnet/libtelnet.c" starts at address 0xd1f38 <_subnegotiate(telnet_t*)+72> and ends at 0xd1f62 <_subnegotiate(telnet_t*)+114>.
Code: [Select]
/home/mud/rlmud/driver/bin/driver(+0xd365a)[0x7f2db9e2565a]
Line 1052 of "thirdparty/libtelnet/libtelnet.c" starts at address 0xd3655 <_process(telnet_t*, char const*, unsigned long) [clone .lto_priv.264]+1301>
   and ends at 0xd3674 <_process(telnet_t*, char const*, unsigned long) [clone .lto_priv.264]+1332>.
Code: [Select]
/home/mud/rlmud/driver/bin/driver(telnet_recv+0x158)[0x7f2db9e14eb8]
Line 1171 of "thirdparty/libtelnet/libtelnet.c" starts at address 0xc2eb8 <telnet_recv+344> and ends at 0xc2ed0 <pop_n_elems(int) [clone .constprop.143]>.
Code: [Select]
/home/mud/rlmud/driver/bin/driver(_Z13get_user_dataP13interactive_t+0x571)[0x7f2db9e3bcd1]
Line 769 of "comm.cc" starts at address 0xe9cd1 <get_user_data(interactive_t*)+1393> and ends at 0xe9ce0 <get_user_data(interactive_t*)+1408>.
Code: [Select]
/home/mud/rlmud/driver/bin/driver(_Z7backendP10event_base+0x26e)[0x7f2db9e18f0e]
Line 259 of "backend.cc" starts at address 0xc6f0e <backend(event_base*)+622> and ends at 0xc6f18 <backend(event_base*)+632>.
Code: [Select]
/home/mud/rlmud/driver/bin/driver(main+0x302)[0x7f2db9d71d42]
Line 168 of "main.cc" starts at address 0x1fd42 <main(int, char**)+770> and ends at 0x1fd58 <main(int, char**)+792>.

11
Drivers / Re: WIP: Fluffos 3.0 Alpha 9.0
« on: November 11, 2015, 02:23:43 PM »
For now i can't reproduce this bug and i can't compile in debug mode (lag for players :()
I'm trying gdb with a coredump for a crash forced by me (for testings purposes)...
When crash again for that error, i'll try it.

Thank you very much!


12
Drivers / Re: WIP: Fluffos 3.0 Alpha 9.0
« on: November 10, 2015, 11:55:40 PM »
hello, trace is:
Code: [Select]
/home/mud/rlmud/driver/bin/driver(+0xd5415)[0x7f2db9e27415]
/lib/x86_64-linux-gnu/libc.so.6(+0x35180)[0x7f2db74c3180]
/home/mud/rlmud/driver/bin/driver(+0xd4a40)[0x7f2db9e26a40]
/home/mud/rlmud/driver/bin/driver(+0xd1f38)[0x7f2db9e23f38]
/home/mud/rlmud/driver/bin/driver(+0xd365a)[0x7f2db9e2565a]
/home/mud/rlmud/driver/bin/driver(telnet_recv+0x158)[0x7f2db9e14eb8]
/home/mud/rlmud/driver/bin/driver(_Z13get_user_dataP13interactive_t+0x571)[0x7f2db9e3bcd1]
/usr/lib/libevent-2.1.so.5(+0x1785c)[0x7f2db807085c]
/usr/lib/libevent-2.1.so.5(+0x209ae)[0x7f2db80799ae]
/usr/lib/libevent-2.1.so.5(event_base_loop+0x49f)[0x7f2db807a32f]
/home/mud/rlmud/driver/bin/driver(_Z7backendP10event_base+0x26e)[0x7f2db9e18f0e]
/home/mud/rlmud/driver/bin/driver(main+0x302)[0x7f2db9d71d42]
/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf5)[0x7f2db74afb45]
/home/mud/rlmud/driver/bin/driver(+0x20475)[0x7f2db9d72475]
******** FATAL ERROR: SIGSEGV: Segmentation fault
FluffOS driver attempting to exit gracefully.
crash() in master called successfully.  Aborting.

This trace is for fluffos 8.1 too :(

i'll try core.

13
Drivers / Re: WIP: Fluffos 3.0 Alpha 9.0
« on: November 09, 2015, 11:48:30 PM »
Do you mean "rlimit"?

WARNING: rlimit for core dump is 0, you will not get core on crash.

Start driver:
Code: [Select]
========================================================================
Boot Time: Tue Nov 10 06:44:02 2015
FluffOS Version: 3.0-alpha9.0(git-944ee22-1443467939)@ (Linux/x86-64)
Jemalloc Version: 4.0.3-0-ge9192eacf8935e29fc62fddc2701f7942b1cc02c
Core Dump: No, Max FD: 65535
Command: ./driver ./config.rl
========================================================================

do you need that load driver with rlimit?
Which is the command for activate it?

14
Drivers / Re: WIP: Fluffos 3.0 Alpha 9.0
« on: November 06, 2015, 01:04:44 AM »
Hello! Today driver crash again.

Same error, in telnet_recv.

Uptime was: around 6 days.

15
Drivers / Re: WIP: Fluffos 3.0 Alpha 9.0
« on: October 28, 2015, 12:31:08 AM »
Hello, yes, for now all is ok!

Pages: [1] 2 3 ... 7